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INSTRUCTIONS FOR USE—WARNING

This product is conform to the 89/336/EEC Directive. It complies with the ITE EN55022 standard for
EMC emissions and generic 50082-1 (1992 edition) immunity standards.

This product is an FCC Class-A apparatus. In a residential environment, it may cause
radioelectrical disturbances.

In addition, this development board is not contained in an outer casing; consequently, it cannot be
immune against electrostatic discharges (ESD). It should therefore be handled only in static safe
working areas. Please refer to Appendix A: EMC Conformity and Safety Requirements on page 67 for
relevant safety information.

USE IN LIFE SUPPORT DEVICES OR SYSTEMS MUST BE EXPRESSLY AUTHORIZED.

STMicroelectronics PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL COMPONENTS IN
LIFE SUPPORT DEVICES OR SYSTEMS WITHOUT THE EXPRESS WRITTEN APPROVAL OF
STMicroelectronics. As used herein:

1. Life support devices or systems are those 2. A critical component is any component of a life
which (a) are intended for surgical implant into support device or system whose failure to
the body, or (b) support or sustain life, and whose perform can reasonably be expected to cause the
failure to perform, when properly used in failure of the life support device or system, or to
accordance with instructions for use provided affect its safety or effectiveness.

with the product, can be reasonably expected to
result in significant injury to the user.
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Note:

4

INTRODUCTION

Thanks for choosing the ST7MDT2-DVP2 development kit! The ST7 DVP2 family
of development kits offer the following new features:

» Delivered with the debugger software package — ST7 Visual Debug!
« Trace buffer recording, viewing and output.
e In Situ Programming (ISP) ability (for MCUs that support this feature).

This manual describes how to start and use the ST7MDT2-DVP2 development kit
for the ST72334 MDT2 CAN-less family and the ST7511R9 MDT2 CAN family of
MCUs, allowing you to get acquainted with the ST7 microcontroller world and
become familiar with the methods for developing and debugging ST7-driven
applications.

If you come across any terms or abbreviations you do not understand, you can check their
meaning in the Glossary on page 73.

This manual also provides a guidance for programming a selection of Flash,
Eprom and OTP (One Time Programmable) ST7 microcontrollers.

The ST7TMDT2-DVP2 development kit contains all the necessary resources that
will help you:

e design, develop and debug ST7 application software running in a real
environment,

e program selected ST7 devices in a variety of modes (refer to Table 3 on
page 39).

First off, check that the ST7 MCU that you have picked for your application is in the
list of devices supported by this version of the ST/MDT2-DVP2:

Supported Devices
ST72124J2/J4

ST72314J2/34
ST72314N2/N4

ST72334J2/34
ST72334N2/N4

ST72532R4
ST72311R6/R7/R9
ST72512R4
ST72511R6/R7/R9

5/82




1 - Introduction ST7MDT2-DVP2 User Manual

1.1

The development kit can be used as a tool to emulate applications on the target
MCU, or as a chip programming tool as summarized in the following sections.

Development board functional configurations
Figure 1 shows the development board of the ST7TMDT2-DVP2 development kit in
an ST7 MCU Emulator configuration.

Figure 2 shows the development board of the ST7MDT2-DVP2 development kit in
an ST7 MCU Programming Board configuration.

Figure 3 shows how you can set up the Development Board to perform in situ
programming of devices on an application board.

LI hutek st wiwinint miatadn m

L.

Parallel cable link

Passive probe

Emulated ST7-MDT2
chip socket on
application board

Power supply

User application
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Figure 1: Using the development board as an ST7 MCU emulator
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PC

Parallel cable link
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Power Supply

SDIP56 / SDIP42
combo ZIF Socket for
programming
ST7MDT2 SDIP
package MCUs

e rerird s d L -

L.

for programming
ST7MDT2 TQFP
package MCUs

Figure 2: Using the development board as an ST7 MCU programming board
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Figure 3: Using the development board for In Situ Programming (ISP)
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Software and documentation for the development kit
The “MCU on CD” CD-ROM contains:

e ST7 Tools, comprising the following software:

The source-level graphic debugger, STVD7, that operates with ST7
development kits and ST7-HDS2 Emulators or as a standalone ST7
simulator.

The ST7 Assembly chain, composed of an assembler, linker, librarian and
formatter.

The ST7 Windows Epromer to program your MCU target devices.

e Third-party C compiler and toolchain demos (Hiware and Cosmic).

e ST7 application notes (with sources), training slides and exercises, this manual
(in PDF version), and other useful reference documents in PDF format, such

as:

Datasheets for the ST7 MCU family
ST7 Programming Manual
ST7 Assembler-Linker User Manual

STVD7 User Manual

About this manual....

Detailed instructions on how to install your development kit configuration is
described in Chapter 2: Getting Started on page 11.

How to start debugging your application using your development kit and STVD7 is
described in Chapter 3: STVD7 on page 15.

How to program devices with the development kit is described in Chapter 4:
Programming ST7 Devices on page 39.

The development kit's hardware features are described in Chapter 5: Hardware
Features on page 47.

The following conventions are used in this manual:

Bold text highlights key terms, phrases and is used when referring to names of
dialog boxes, windows and tabs within windows.

Bold italic text denotes menu commands (or sequence of commands),
options, buttons or check boxes which you must click in order to perform an
action.

4
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Italicized text highlights document names, variable strings, column names and
field names.

Code font designates file names, programming commands, path names and
any text you must type.

The > symbol is used in a sequence of commands to mean “then”. For
example, to open an application in Windows, we would write: “Click
Start>Programs>ST7 Tool Chain>....".

1.4 Getting assistance

For more information, application notes, FAQs and software updates on all the ST
microcontroller families, check out the CD-ROM or our website:

http://mcu.st.com

For assistance on all ST microcontroller subjects, or if you need help with using
your emulator, use the contact list provided in Product Support on page 77. We'll
be glad to help you!

9/82
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2.1

2.2

4

GETTING STARTED

Your system requirements

The ST7TMDT2-DVP2 development kit (both hardware and software components)
has been designed to work with PCs having the following configurations:

One of the following operating systems: Microsoft® Windows® 95, 98, 2000 or
NT®.

Intel® Pentium (or compatible) processor with minimum speed of 100 MHz.
Minimum RAM of 32 MB.

21 MB of free hard disk space to install all of the ST7 tools.

Delivery checklist
The ST7/7MDT2-DVP2 development kit contains:

1

One development 1) )
board
(Ref.: MB289).

One parallel
cable for PC
connection and
two EMC ferrites.

(3 4)
One 5V external '

DC power supply
with female
connector cable
(two possibilities
exist).

SDIP56 passive
probe connector ©) (6)
(Ref.: DB347)

and two 50-pin
flat cables.

oe Toreee |7 ) W] [[ ©
passive probe

connector (Ref.: DB404) and one SDIP56 to SDIP42 (ref.: DB326) device
adapter.

One ISP 10-pin flat cable for in situ programming.
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Note:

2.3

Note:

Caution:
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One Yamaichi QFP64 socket, with its cover, screws and washers. (Not shown.)

7

8 One MCU-on-CD CD-ROM.(Not shown.)
9 This manual.(Not shown.)
A

TQFP44 passive probe is available for the ST7MDT2-DVPZ2 but must be ordered
separately. Contact your nearest STMicroelectronics sales representative (see page 77).

Installing the hardware

To install the hardware, follow these steps:

1 Shut down and power-off the PC that is to be connected to the development
board.

2 Connect one end of the supplied parallel cable to the parallel connector (P2) on
the development board. Connect the other end of the parallel cable to the LPT1
or LPT2 parallel port on your PC.

The supplied parallel cable has been tested in order to operate properly on most PCs. Do not
use any other cable, especially if it is longer than the one provided in the kit—the board may
not operate properly.

The cable should be connected directly to the DB-25 female connector of the PC parallel port.
This connector is similar to the one installed on the board. Do not insert any additional cables
or switchboxes between the PC and the board: a malfunctioning of the board may result.

If a dongle is mounted on the PC parallel port, it should not interfere with the programming
board. Should you notice that the board is dysfunctional, remove the dongle and restart the
installation procedure.

3 Connect the two 50-pin passive probe cables to J1 and J2 on the development
board.

4 To the other ends of the 50-pin cables, connect the passive probe and/or device
adapter corresponding to the MCU package you wish to emulate:

- SDIP56 passive probe alone for SDIP56 MCU packages.
- TQFP64 passive probe alone for TQFP64 MCU packages.

- SDIP56 passive probe with the SDIP42 device adapter for SDiP42 MCU
packages.

Special precautions are required if you are using the TQFP64 package. Because there is no
Yamaichi socket available specifically for the TQFP64 footprint (a QFP64 Yamaichi socket is
furnished instead), there are special footprint precautions to be taken when designing your
application board (see Section 5.7.2: QFP64/TQFP64 footprint discrepancy issues on
page 59).

4
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5 EMC-Compliant Probes (optional): In order to work under an EMC-compliant
environment, you will have to clip one EMC-ferrite on both 50-wire flat cables
linking the application to the development kit board. Place this ferrite as close to
the development kit board as possible. You also need to clip one EMC ferrite on
the power supply wire coming from the power supply box. See Figure 4 on
page 13.

Clip ferrite closed

Clip ferrite closed . A
: B

Figure 4: Connecting the ferrites

6 Connect the passive probe to the appropriate socket on your application board.

For the TQFP64 passive probe, a Yamaichi QFP64 socket has been included.
Follow the instructions in Section 2.4 on page 14 to connect the TQFP64
passive probe to your application board.

7 Plug the DC power supply provided with the development kit into a power outlet.
Connect the power cable to the development board. The green Power LED will
light up.

Note: The development board can also be fed via the JP1 connector by an external stabilized power
supply (5 V+0.25V, 1 A) not provided with the Kit.
If the board is fed via the JP1 two-point connector make sure that the right feeders lead to the
right polarities.

8 Power on the PC and proceed with the installation of the software as described
on Section 3.1 on page 15).

Caution: Do not use the jumper connections TP17, TP4 and TP5 — they are for factory testing only and
modifications to them could cause your development board to malfunction. Refer to Section
5.5 on page 50 for a description of all jumpers and solder connections on your development
board.

13/82
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Connecting the TQFP64 passive probe to your application board

A Yamaichi QFP64 socket and its cover are provided in the package
(Ref.: DB200). Before going through the procedure, make sure that you were
properly delivered the socket, its cover and its screws and washers.

To connect the TQFP64 passive probe to your application board, proceed as
follows (see following figure for flow order):

1 Solder the Yamaichi QFP64 socket base onto your application board (see
Section 5.7.2 on page 59 for footprint information). Do NOT screw the socket
cover onto its base.

2 Place the end of the TQFP64 passive probe onto the Yamaichi socket base,
taking care to align pin 1 of your application board with pin 1 of the passive
probe. Pin 1 is indicated by a chamfer on the passive probe and by a little arrow
or chamfer on the Yamaichi socket.

3 Once placed, you can screw the TQFP64 passive probe onto the Yamaichi
socket using the four threaded holes located on the upper surface of the
passive probe.

Two 50-pin
flat cables

TQFP64 passive

probe (Ref.: DB404) Threaded holes

Yamaichi socket to solder

N N I}
T T 1 T

@i@l

Application board

Figure 5: Connecting the TQFP64 probe to your application board

If you require supplementary sockets, the commercial references of Yamaichi
QFP64 sockets are given below:

QFP64/TQFP64 Yamaichi socket WITH positioning pins IC149-064-108-S5

QFP64/TQFP64 Yamaichi socket WITHOUT positioning pins IC149-064-008-S5

b7
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Note:

4

STVD7

STVD?7 is an integrated development environment that allows you to edit, debug
and rebuild your application all from within STVD7.

The following sections tell you:

Section 3.1—how to install the STVD7 software,

Section 3.2—how to launch STVD7,

Section 3.3—a little about STVD7’s debugging features,

Section 3.4—what a workspace is,

Section 3.5—what toolchains and executable files are supported by STVD7,
Section 3.6—how to create a STVD7 workspace,

Section 3.7—how to open existing workspaces,

Section 3.8—how to open binary files,

Section 3.10—how to change your project settings,

Section 3.11—how to save workspaces,

Section 3.12—how to switch from the build context to the debug context,

Section 3.13—how to configure the target MCU in order to debug more
accurately and efficiently.

Installing STVD7

Your development kit comes with the “MCU on CD” CD-ROM which contains a
number of ST7 software tools. These tools run under the Windows® 95, 98, 2000
and Windows® NT® operating systems.

To install the software on “MCU on CD”, Windows® 2000 and NT® users must have
administrator privileges.

To install and setup the ST7 software tools, follow these steps:

1
2

Close all other open applications on your Windows desktop.

Insert the “MCU on CD” into your CD-ROM drive. The CD-ROM'’s autorun
feature will open up a welcome screen on your PC. If the autorun feature does

not work, use Windows® Explorer to browse to the CD-ROM'’ s root folder, and
double-click on W&l cone. exe.

Select Install Your Development Tools from the list of options. A new screen
will appear listing the different families of STMicroelectronics MCUs.

Use your mouse to place the cursor over the ST7 Tools option. Choose
ST Tools, then ST7 Toolchain from the lists that appear.

15/82
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5 The install wizard will be launched. Follow the instructions that appear on the
screen.

You can choose to install the complete toolchain (i.e. the appropriate version of
STVD7, the Windows Epromer and the Assembler-Linker) for each type of
development tool (development kit, HDS2 or EMU3 emulators or simulator), or
perform a customized installation.

If you choose a customized installation, you can choose to install any or all of
the STVD7 versions, and/or the Windows Epromer and/or the Assembler-
Linker. As a minimum, in order to emulate and program your application
with your DVP, you must install STVD7 for DVP and the Windows
Epromer.

If you also install the ST7 Assembly Toolchain, you will be able to use the ST7
Assembly Toolchain as part of STVD7’s integrated development environment.

The installation is now complete. You will be prompted to reboot your computer.
You should do so before launching STVD?7.

Launching STVD7

1 From vyour Windows desktop, select Start>Programs>ST7 Tool
Chain>Development Tools>STVD7 Development Kit.

2 The first time you open a
version of STVD7 you will be
prompted to enter the
toolchain paths to be used Cosmic builder path:
by STVD7's integrated |CACOSMICIST?
development environment.

Toalchain Path

Hiware builder path:
Enter the paths for the

toolchains that you use (i.e. IEAHIW&HE&PHDG —I
any or all of the Hiware, ST7 Assembler path:

Cosmic or ST7 ASM IE:'\F‘ngram Files\5 Tk st Ptoolchain's
toolchains) and click OK.

(The default paths for each

toolchain are shown below.) oK, Cancel

3 If you choose Cancel, you
will be prompted again to enter the toolchain paths the next time you launch
STVD?7.

You may modify the toolchain path at any time from within STVD7—simply select
Project>Toolchain Paths from the main menu to access the dialog box above.

4
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3.3

4

About STVD7 debugging features

A number of advanced features are included in the STVD7 software:

Data Breakpoints on the occurrence of a memory access via a read operation
or a write operation, or both.

Instruction Breakpoints on the occurrence of an opcode fetch.

A Trace window to view the contents of the trace buffer, which permanently
records in real time on 32-bits:

- Address and data bus information.

- Flag status and 4 external signal values.

You can record up to 256 executed cycles. Using trace filtering, you can filter
out only those cycles you wish to record in the trace buffer. You can equally
control which of the recorded cycles are displayed in the Trace window using
line filtering. Addresses, data, control/status bits and 4 user signals are
displayed using mnemonic and user symbols.

Hardware Events can be used to control the trace recording or the sending of
signals to the trigger outputs.

A powerful online help facility can be invoked at any time to give additional
information about the commands, the processor or the emulator kit.
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Workspaces

STVD7 organizes project development and debugging into workspaces.
Workspaces allow you to store application and project settings and save them as a
* . wsp file, so that each time you wish to work on the project, you will find all of the
settings exactly as you left them.

Creating a workspace is the first thing that you need to do when using STVD7 for
the first time or when starting any new project. You must have an open workspace
to work with STVD7. How to create a new workspace is described in detail in
Section 3.6 on page 22. Sample workspaces for each supported toolchain are
provided so that you can familiarize yourself with STVD7 (for a listing of sample
workspaces, see Table 1 on page 20).

Each workspace is comprised of three information sets: the project settings, the
visual environment and the debugging context.

e The project settings consists of the information necessary for a successful
build of an application (commands to run, makefile file etc....). Your
workspace’s project settings include the definition of your application toolchain
(see Section 3.5 on page 19).

e The visual environment consists of the open windows elements along with
their current layout, bookmarks and other features. The visual environment is
composed of two environments, one in the Build context and one in the
Debug context (see Section 3.12 on page 32).

e The debugging information includes information on breakpoints, memory
mapping, advanced breakpoints programs, trace etc..

4
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4

Toolchains and application files

A quick summary of development toolchains and application file types supported
by STVD7 will help you in setting up your workspace.

Three different development toolchains are currently supported by the STVD7.
Each type of toolchain has its own application and executable file types, project
environment and building tools (i.e. linkers and convertors):

The ST7 macroassembler toolchain from STMicroelectronics, which
generates either . s19 or . hex executable files with various intermediate files,
such as . map or. | st files.

The Hiware C or Assembler toolchain, which generates . abs executable
files with various intermediate files, such as . o or . dbg files.

The Cosmic C or Assembler toolchain which generates . el f executable
files with various intermediate files, such as . o or . st 7 files.

When you set up a workspace, you will need to define the following project
settings:

The toolchain to be used— Hiware, Cosmic or ST7 macroassembler.

The executable file (*.abs, *.elf, *.s19 or *.hex depending on
toolchain—refer to Table 2 on page 21).

The maker program for the toolchain. The maker program can be a part of the
toolchain software (such as Hiware’s maker . exe) or you can choose to use a
generic maker such as Nmake. exe or Grake. exe (which is provided with the
STVD7).

The maker batch file (*. nak or *. bat ). This is a file which you create for
each application which spawns the compilation and/or link step each time you
wish to build or rebuild. In it, you define the conditions for recompiling, re-
linking or both.

Default *. mak or *. bat files are often included with the toolchains—for
example, naker. mak is included with the Hiware toolchain and simply
recompiles your application if it detects that the file has been saved since the
start of your debugging session. The STVD7 software includes sample *. mak
and/or *. bat files for each toolchain—these are listed in Table 1.

19/82
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Table 1: Sample files included with STVD7

Toolchain

ST Macro
assembler

Sample Workspace (with
default path

...lrealtimrealtimwsp

Sample Make and/or Batch
files (with default path?)

...lrealtimtimrtc. bat

Description of
Make/Batch File

Batch file that
forces a recompile
of the application.

.../ spiml/spiml. wsp

./ spimll/spiml. bat

Batch file that
forces a recompile
of the application.

Cosmic

...lclcosmc/sanpl e.wsp| ..

./ c/cosm c/ sanpl e. mak

Recompiles only if
one (or more) of

the application files
has been resaved.

./ c/cosm c/ sanpl e. bat

Batch file that
forces a recompile
of the application.

Hiware

... /Iclhiware/sanpl e. wsp

./ ¢/ hiware/build. mak

Recompiles only if
one (or more) of

the application files
has been resaved.

./ c/ hiware/rebuil d. mak

Forces a recom-
pile of the applica-
tion.

1) The full default path is: C./ Program Fil es/ St m st 7t ool chai n/ stvd7/
dvp/ sanpl e/ . ..

3.5.1 About executable files

The user should verify that the options to include debug information were active
during creation of the project files. Table 2 on page 21 summarizes the way each
toolchain functions and lists the different file types (source files, intermediate files
and executable files) used and produced by the toolchain. The executable file
types and intermediate file types necessary to exploit fully the STVD7
capabilities are listed.

20/82
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Table 2: Toolchain steps and their output files

Toolchain: ST Macroassembler Hiware Cosmic

Compile or Assemble Step:

Source File .asm .C, .asm|.c, .s
Types
Required asm-li macrost7.asm <NONE> +debug
Options
Resulting File | . obj, .l st .0, .dbg |.o0
Types

. _______________________________________________________________________________________________|
Linker Step:
Required lyn macrost7.obj, macrost? <NONE> <NONE>
Options asm macrost7.asm -sym -fi =macrost 7. map
Resulting File | . map, .| st . abs .st7
Types

. ____________________________________________________________________________ _____ __________|
Converter obsend macrost7, f, macrost7.s19, srec not cvdwar f
Step: or applicable

obsend macrost7, f, nmacrost7. hex, intel

Resulting .s19 or .hex . abs, .elf
executable .elf
file:

. ____________________________________________________________________________ _____ __________|
Necessary .map, .Ilst .0, .dbg | <NONE>
Intermediate
Files:

The executable file(s), source files and any necessary intermediate files (these
are listed above and contain debug information necessary to the STVD) should be
located in the same project directory. You do this when you define your workspace.

Note: It is always preferable to have access to all of the files generated by the development
toolchain. However, you can load *.s19 or *. hex binary files directly and have limited
debugging capabilities (refer to Section 3.8 on page 26).
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Creating a workspace

1 Select File>New Workspace. This command opens a new window where you
define the name of your workspace and the directory in which you want to work.

Hew Workspace Ed |

Wiorkzpace filenarme:

Im_l,lw::urk]

Wiorkzpace locatian:

IE:'\F’mgram FilezhS T st toolchain®, _I

Mewt »

Cancel

4
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4

2 Then, click Next>. The New Workspace: Project Settings dialog box

appears:
New Workspace: Proect Settings G|

Woorkspace filename: I Comy vk mnpwiork. wep
Software Toolchain: IST.'-" Hiware Toolchain j

 Executable
Filenarne: Isample"m'xhiware'xsample.al:us _I

— Build
taker: I Hiwsare mak.er j
bdaker filenanne: |D:"~HIW.&F|E"\F'FIEIG"«maker _I
takefile or batch file: |$ample"u::"-.hiware"-.l:nuild.mak _I
"Build" cormmand line: Imaker build. rak
"Rebuild A" commmand line: |maker rebuild mak
Start "Build" # "Rebuild A" i ISEII'I'II:I'EI'\C"'.hiWETE _I

< Back. Einigh Cancel

Here you enter your software toolchain, your executable filename and your
build parameters either by typing or using the drop boxes.

Select the toolchain and enter the name of your application’s executable file.
For example, if you wish to use the Hiware toolchain for ST7, your executable
file will be of type *. abs (refer to Table 2 on page 21)—click on the browse

button | to browse to the folder where your executable file is saved and
select it.

Next, choose the type of maker your application uses from the drop down list. In
the example above, we have chosen the default Hiware maker, naker . exe.

STVD7 will automatically look for this maker file in the folder you defined as the
Hiware toolchain path.

Finally, you must define a make file or a batch file. There are several sample
files provided with STVD7 (see Table 1 on page 20). Here we have chosen
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bui | d. mak as the default make file, used when the Build command is issued,
and r ebui | d. mak as the make file to use when the Rebuild command is
issued.

6 After you have finished defining your project settings, click Finish.
Once the workspace is opened, the Workspace window displays its contents.

When you create a new workspace, the first time you switch to Debug context (see
Section 3.12 for an explanation of STVD7 contexts), the MCU Configuration
window will automatically open to prompt you to choose you target MCU and
confirm or modify its option and memory configuration (see Section 3.13 on
page 33).

Opening an existing workspace
If you have already created a workspace, you simply need to open it in order to
load all of your project settings into the STVD?7.

There are a number of sample workspaces provided with STVD7 that you can open to get
familiar with STVD7. These samples are listed in Table 1 on page 20.

1 From the main menu, select File>Open Workspace.
This command opens a window where you can browse to any folder you wish,
and select an existing workspace.

OponWorkspace ____________HE|
Look in: IaDebug j | ﬁil e |
Dsample

My v ark s

File narme; || Open

Files of wpe: IST? Project Workzpace [*.wsp) j Canicel

4
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2 The Workspace window opens.

2=l
When a workspace is opened, all = Hgsl mywork.wep
of the predefined project settings El B samplebethivarehbuild mak
are loaded into the STVD7. The -~ [ sampletcthinaretsample. abs

Workspace window will show a
structured representation of the
project. For example,
mywor k. wsp shows that it uses
bui | d. mak as the make file and
sanpl e. abs as the executable
file.

Although the name of the executable file
is shown in the Workspace window, it has
not yet been loaded into the emulation
memory—see page 26.

If you click on the Source 5] Workspace 3y Sauree Directo...
Directory tab, the window will

show every source and intermediate file type (*. ¢, *. s,*.asm™*. hor*. 0) in
the selected directory.

=l
=gl C :“Program Files\5 Tk et Ptoolchain's
zamplel.c
zampleZ. azm
zampled.c
start]?.c
gtartdy.h
-1 Double click here...
1 | il
@ Workspace () Source Direct... |-

3 If there are no source files shown in the Source Directory tab of the Workspace
window, or you wish to list additional files stored in another folder, you may
browse to them by clicking the Double Click here... folder. The Add Source
Directory window pops up allowing you to enter or browse for a new directory,
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and filter out the file types of interest. You may also choose to specify a
directory that is relative to the workspace directory by clicking on the Path
relative to the Workspace directory option.

=
=L C:vProgram Files'

zamplel.c

I

zample. asm
zampled.c

b start7.c
Do

startdy .k

uble click here

Add Source Directory [ x| |

[T Path relative ta the Workspace directon

Fath: D:hzampleshsampled |

Filez filker: I".n: Fhamm Foe finc® eppt bat T|

Ok Cancel

<

Elnior... 1) Sou... |

4 To load the executable file, as well as any intermediate files, click the Debug

icon D) or the Reset Chip icon . The application and symbols will be
loaded. Before you can start debugging, you must set the target hardware
device by configuring the MCU.

Opening binary files

If you do not have access to the source or intermediate files generated by a
toolchain, you may also load *. abs, *. s19, *. hex or *. el f files on their own
using the Open Workspace command.

If you try to open*. s19 or*. hex files using the following procedure, STVD7 assumes that
these files have been generated using the ST7 Assembler-Linker toolchain, and that it will
find the *map files in the same directory. If you have ONLY the *.s19 or *. hex files
available, instead use the procedure given in Section 3.9: Opening lone programmable files
(*.s19 or *.hex) on page 27.

The range of debugging features available when you open a binary file only will be
very restricted. You will only have access to basic debugging windows, such as the
Disassembly and Memory Windows.

b7
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1 Launch STVD7 and select File>Open Workspace from the main menu.

2 Browse to the folder where your binary file is stored, and select ST7
Application files (*.abs, *s19, *.hex, *.elf) in the Files of type field.

DpenWokspace G
Laak jn: I'al'ﬂ.'r'_wmk j El

my_project. abs

File name: Im_l,l_pn:uieu:t.al:us Dpen I
Files of twpe: IST? Application files 7 abs;”513;% hew” elf] j Carcel |

3 Select your binary file (*. abs, *. s19, *. hex or *. el f) and click Open.

The binary code in the executable file will be loaded into STVD7 and you will be
able to access the Disassembly window and the Memory window. A workspace file
(of the same name as the binary file, but with an extension . wsp) will be created
automatically.

Opening lone programmable files (*.s19 or *.hex)

If you do not have access to them *. map file generated by the ST7 toolchain, you
may also load isolated *. s19 and *. hex files from within STVD?7.

The range of debugging features available when you open these files will be very
restricted. You will only have access to the Disassembly Window and the
Memory window.

1 Launch STVD7 and select Debug>Start Debugging from the main menu or

click on 'E .

2 Open the Memory window by selecting View>Start Debugging from the main
menu.

3 With the cursor in the Memory window, right-click the mouse to open the
Memory contextual menu.
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4 Inthe Memory contextual memory, select File>Restore Layout. The Load File

to Memory window opens.

5 Browse to the folder where your programmable file is stored, and select either

the Motorola format (*.s19) or the Intel format (*.hex) in the Files of type field.

Load File to Memory |
Lookjn: |3l Temp = ﬁl
spim11.519

Filz narne: Dpen

[ Oeen |
Cancel |

Filez of type:

6 Select your programmable file (*. hex or *. s19) and click Open.

The binary code in the . s19 or . hex file will be loaded into STVD7 and you will be
able to access the Disassembly window and the Memory window. A workspace file
(of the same name as the programmable file, but with an extension .wsp) will be
created automatically.

Changing your project settings

The Project menu contains the Build and Rebuild All commands you need to
recompile your application after having made changes to it in the course of
debugging. You may also access your project or toolchain settings in the event you
wish to change them.

| Froject

(] Build F7

Riebuild All

StopiBuid

Project Settings... Alt+F7F
Toolchaing Path...

4
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From the main menu, select Project>Project Settings.

Project Settings E |

Wiorkzpace filename: wiharchatvdebughDebughsampletcizample. wap

Software Toolchain: IST.'-" Hiwsare Toolchain j
— Executable

Filenarne: Isample. abs _I
— Build

b aker: I Other maker j

b ak.er filename: IE:"-.HIWI—‘«FIE"-.F'FIDG'\Maker.EHE _I

b ak efile: ISampIe. mak, _I

"Build"” command line: IMaker.EHe sample. mak.

“Rebuild A1 command |Maker.e:-:e sample.mak.

_Stf”t "Build" / "Rebuild A" IE:Wiew'w::ul:u'xgui'xstvd'xsrc'xstvdebug'\[)e _I

ok Cancel

You can change your settings here and continue running your application. When
you exit STVD7, the system will ask you if you want to save these settings in the
workspace you have been working in. If you choose yes, these will become your
new workspace settings; if you choose no, these settings will be lost.
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The Toolchain Path... item invokes the following window:

Toalchain Path x| I

Cogmic builder path:

|CACOSMICIST?

Hiware builder path:
IE:'\HIW.&FHE'\F'FHEIG

ST Azzembler path:
II:: WProgram FileshS Th st Proolchainhz

amreennney

k. Cancel

In this window, you can define your builder and/or Assembler paths. Clicking _I
opens a browser window.

Saving workspaces

Whenever the current workspace is closed, it is automatically saved. This can
happen either when exiting STVD or opening or creating a new workspace.

In addition to this, a workspace can be explicitly saved with the File>Save
Workspace... or File>Save Workspace as... commands.

The user is given the choice of which of the workspace elements to include in the
saved file. Either the visual environment or the debugging information may be
saved alone, or both may be saved together. This is configured as follows:

1 From the main menu, select Tools>Options.

2 In the Options window that opens (see Figure 6 on page 31), select the
Workspace tab.

3 Choose whether you wish your saved workspace to include either the visual
environment or the debugging information or both.

4
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4 Select which windows will appear docked when a project is opened by checking
the appropriate check boxes in the Floating windows in the main frame area.
Only windows currently docked in the main window can be included.

N -

Tn:n:nll:narsl Enmmandsl Edit/Debug ‘Workspace |

Floating windowsz in the main frame:
Wiorkspace includes:

Cutput ¥ Wizual environment
Dizaszembly
b ermory
Inztuction Breakpaints
Watch
Call Stack
Local Y ariables
5T7 Data Breakpointz
5T7 Reogisters
5T7 Peripheral Reqisters

¥ Debugging contest

] I Cancel SEply

Figure 6: Options window

5 Click Apply to confirm your settings.
6 Click OK close the dialog box.

In addition, open file contexts and current window positions are saved when the
workspace is closed. This feature restores the workspace window, window layout
and file views to that which was current when STVD7 was closed. The toolbar
layout, plus customized toolbar content is also saved and restored with the
workspace (options set via the tabs entitled Toolbars and Commands).

By default (i.e. when saved automatically) the workspace is saved as file
<application>wsp. The name of the file corresponds to the name used for the
executable file (for example, <application>.abs for a Hiware executable file).

Using the Configuration Setup dialog box (available from the MCU Configuration dialog
box), you can also control what type of MCU configuration information is restored from a
workspace file (*.wsp).
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Debug context and Build context

There are two STVD7 contexts, the build context and the debug context. Until
now, in creating a workspace, and defining your project settings, you have been in
the build context. To proceed step—configuring your MCU—you need to change to
the debug context.

Briefly, the two contexts are different in that:

« In the build context, you can open and close workspaces and build or re-build
the application executable file.

e In the debug context you set the emulated MCU configuration (this step is
described in Section 3.13 on page 33) and debug the executable file created
while in the build context.

Build Context

The build context is the context set when starting STVD7. In this context, it is not
necessary to be connected to a development kit and the debug commands are not
available. You can also edit the source files of an application and perform the use
the Build command to perform compile and link actions in an interactive and
iterative way to re-build the application executable file.

Debug Context

In this context, the following debug actions can be carried out:

« Loading, running and stopping the application.

» Defining the MCU configuration (MCU options and memory mapping).
* Viewing source and disassembled code.

e Setting instruction breakpoints with a counter and/or condition.

e Setting data breakpoints.

* Viewing local variables, memory and ST7 registers.

« Viewing history of execution from the trace buffer or with the Call Stack feature
analyzing the performance of a piece of code.
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Switching between contexts

The switch between contexts usually occurs when the Start
Debugging and Stop Debugging commands are used:

©

From the main menu, choose Debug>Start Debugging or
Stop Debugging or click on the Start Debugging or Stop

Debugging icons shown at right.

While debugging, the editor allows source files to be
modified. To switch to the Build context perform either a
Build or Rebuild action or use the Stop Debugging
command.

©

Stop Debugging

Configuring the MCU

After you create or open a workspace, the next step you must perform before
starting your STVD7 debugging session is to define and configure the target device
(MCU) that you wish to emulate.

The target device is defined and configured from the MCU Configuration window.

1 First, ensure that you are in Debug context by clicking on o . (STVDY has
two contexts: Debug context and Build context—these are described in
Section 3.12.)

The first time you enter into the Debug context after having created a new workspace, the
MCU Configuration window will be opened automatically.

2 Select Tools>MCU Configuration from the main menu. The MCU
Configuration window will open.
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An example of a typical MCU Configuration window is shown in Figure 7.

MCU Configuration - ST7 XXM XXX

MCU Name field

—Zoom

MCU name: IST?XXXXX "I From To T_'JPE! I 256: 16X16 << I ' Selection auto zoom ]7
00000 | 00002 | PERIPH SYSTEM 0:0100

T Value | [ 0x0003 | 0:0003 | RESERVED Mm— *

VD 5.V.. | OFF 0x0007 | 0x0007 | RESERVED  [aFSERVED

CLOCK_FI | OFF 00008 | 0x000a | PERIPH 0x00c0

EXTIT | ITOPA/AT.. | | 0¥000b | 0x001F | RESERVED

CLOCK DN_BDAHD 0x0020 | 0x0026 | PERIPH

SO | o02s | D0ze | PERPH

HALT_AN... | RESET L e s

= 0x002f | 00030 | RESERVED Lt t%
00031 | 0x004f | PERIPH
0x0050 | 0x006f | RESERVED
0x0070 | 0x0071 | PERIPH ;0......%030.X*:’:’:'i*:’:’:*:*.’.’:*:::z..‘: o
040072 | 0x007f NGESERVED LEre 030'3:5:5:3:3':‘0o"":E:‘:E:::::::go’:3:3’??5'5’:
00080 | 0x013f_| PG .&::3*.:&':':’:’:1%?.'. RS EGESETEE
0x0140 | 02017f SNCK 60002]
i / .
T i) pt K
Vo |
0K Cancel | Contf... I Insert | / I edify | Delete
/

\

Option configuration
fields

\

Memory configuration

fields

/

Graphic memory
configuration viewer

Note:

Note:
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Figure 7: MCU Configuration window

The options shown in the above example may not be available for your particular target MCU.

3 Set the Target MCU. In the MCU name field, select the target device for which

the application is intended from the dropdown box. Once a target MCU has
been chosen, the Option configuration and the Memory configuration fields will
show the default values for this device.

Configure the MCU Options and On-Chip Peripherals. All of the
configurable options on your target hardware device are listed in the Option
configuration fields. Beside each option, a default value is given. You may
change this value by clicking on it and choosing a new value from the drop
down list. This allows you to configure your target device’s options and on-chip
peripherals. Depending on the MCU selected, the default settings in the Option
configuration fields will change. It is up to you to configure those options that will
impact your application so that the development kit accurately emulates your
target device.

For more information about the configurable options available on your target hardware
device, please consult your target MCU'’s datasheet.
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5 Configuring the MCU Memory. The default memory settings depend on the
MCU selected. However, you can configure the memory settings as you wish if
your application requires non-default settings. This feature would enable you,
for instance, to temporarily increase the ROM size during the development
phase of your application.

— £00Mm
From To Type I |11 11 o | b | Selection auto zoom [
0x0000 | 0x003f | PERIPH B2 TEMSS [l 0000
0x0040 | 0«00 | Rk T §
0x0100 | 0x013f | STACK BAM
00150 | Ox0=ff | RESERVED ==
Ox0f00 | Oufff | SYSTEM 0000
0:1000 | Oxefff | RESERWED
0000 | Oxffdf | ROM
Oxffel | OxFfF YECTORS 08000
4000
x003¢ H
Cant... | [rzert | / ol mdify | Delete

\

Memory Graphic memory
configuration fields configuration viewer

There are two methods for configuring the memory settings on the MCU: by
typing in the start and stop addresses of each memory zone into the memory
configuration window, and by graphically moving the memory zone
boundaries in the graphic memory configuration viewer (see page 36 for
more instruction).

Memory zone types

The left column of the memory configuration window indicates the address
range of each memory zone. The right column indicates the memory type of each
zone. Depending on your target MCU, the available memory types may be:
Peripherals, RAM, ROM, Stack, System, EEPROM, Reserved, Vectors,
Application. Some of these zones can have their type and size modified, others
cannot be modified. Their definitions and properties are explained as follows:

4
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Peripherals: Microcontroller internal or rebuilt peripherals registers. Their
properties are defined as in the microcontroller datasheet. This memory
cannot be modified.

RAM: Random-Access-Memory of the microcontroller. This memory type can
be modified.

ROM: Read-Only Memory of the microcontroller. Write protected. This memory
type can be modified.

Stack: Stack of the microcontroller. This memory type cannot be modified.

System: The development kit uses this space for emulation management. This
memory type cannot be modified.

EEPROM: This memory is internal to the microcontroller and is located inside
the emulation device. The programming of this zone is done according to an
automaton found in the datasheet. This memory type cannot be modified.

Reserved: This memory zone is reserved as on the microcontroller. It is not
allocated to any use and is write protected. This memory type cannot be
modified.

Vectors: This memory zone contains the user interrupt vectors zone. It is write
protected. This memory type can be modified.

Application: This memory type is microcontroller-specific. The user can add
memory or peripheral resources on its hardware. It is not available on every
development kit. Properties are linked to the user hardware. This memory type
can be modified.

For most target MCUs, you may modify the following types of memory zone: RAM,
ROM, Reserved and Application. This feature would enable you, for instance, to
temporarily decrease the RAM zone, increase the size of the ROM (to exceed what
is available on the real microcontroller) during the first stages of development.
Once your program is functional, you can start to optimize its size by reducing your
code and returning these zones to their original size. There are two different
actions you may perform on the memory configuration:

change the type of an entire existing zone.

define a new zone of any type wherever possible.

To change an existing memory zone:
1 Select the memory zone to be modified.

4
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2 Click on the Modify button at the bottom of the window. A New MCU Memory
Range dialog box will open, allowing you to change either the address range
and/or the memory type of the memory zone.

Mew MCU memony range
Fram : IEIHEIEIED Tor IEI:-:EI'I 3f
Type:  [RAM j

FERIFHERALS

Ol STACK Cancel |
EFR

EEF
VECTORS

To create a new zone of any type:
1 Click on the Insert button. The New MCU Memory Range dialog box will
appear.

2 Enter the address range of the new memory zone in the From and To fields.
3 Select the type of the new memory zone in the Type field.
4 Click OK to validate your choice.

The new memory zone will then appear in the MCU Configuration window unless
you tried to create a new zone in a nhon-modifiable memory space (such as Stack
or EEPROM).

To use the Graphic Memory Configuration viewer:
1 In the memory configuration window, click on the zone whose boundaries you
wish to move.

2 Check the Selection auto zoom box in the upper right-hand corner. The
graphical view of the memory configuration will be scaled so that the zone you
have selected is easily visible.

3 At the upper and lower boundary of the zone, at the left-hand side of the
graphical viewer, you will see a small triangle and rectangular box giving the
boundary addresses of the memory zone. You can change a boundary address
by dragging and dropping the triangle with the mouse to its new location. The
triangle can be moved either up or down, left or right in the graphical viewer.

The MCU configuration that you specify will, by default, be saved in a workspace
file (*. wsp) for the project. The next time the application is opened, the STVD will
automatically set the MCU configuration (as well as the layout of opened windows
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and other debug information) to the same conditions you had when you left the last
debugging session.

If you do not wish your MCU configuration information to be saved in the
workspace file, you must alter the default Configuration Setup options by clicking
on the Conf... button.

Start debugging!

Once in debug context, you are now ready to start debugging your
applicationusing the development kit. Full documentation on how to:

e control your STVD7 work environment
e use its integrated editor
e use the many debugging windows and features

is available from the online help and the online STVD7 user manual, located under
Help in the main menu.
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PROGRAMMING ST7 DEVICES

Table 3.

Table 3: Programmable devices

Once bug-free and ready for operation, your application program needs to be
transferred into an ST7 MCU program space.

With the ST7TMDT2-DVP2 development kit, you may program the MCUs shown in

Supported Device

Programmable Memory Type1

Programming method(s)?

ST 7212432134

EEPROM and OTPROM

ZIF Sockets® and ISP

ST 72314J2/34
ST 72314N2/N4

EEPROM and OTPROM

ZIF Sockets and ISP

ST 72334J2/34
ST 72334N2/N4

EEPROM and OTPROM

ZIF Sockets and ISP

ST72532R4 EEPROM and OTPROM ZIF Sockets
ST 72311R6/R7/R9 EEPROM and OTPROM ZIF Sockets
ST 72512R4 EEPROM and OTPROM ZIF Sockets
ST 72511R6/R7/R9 EEPROM and OTPROM ZIF Sockets

1) For more information about the programmable memory for each target device,

refer to the target device’s datasheet.

2) For descriptions of programming methods, see Section 4.2 on page 41.

3) SDIP56, SDIP42 and TQFP64 packages are programmable using the ZIF
sockets provided with the development kit. TQFP44 packages are not sup-

ported by the development Kit.
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Device programmer features

Figure 8: General eproming architecture

External Power Supply

5V=/1A

DC/DC converters
12V

5V

3.3v

-—

PC Parallel Port Interface

PC HOST

Microcontrollers to
program:

SDIP56/42

5V / 12V Power contrdl

ST/MDT2-DVP2 Main Board

SDIP42/56

ZIF Programming L

Sockets

TQFP64

ST7-MDT2-
TQFP64

ISP
Connector

|
|
A/ A |
|

4L
A4
10 pin ISP flat cable
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Programming methods

ZIF sockets

The ST7MDT2-DVP2 development board is provided with a SDIP56/42 Zero
Insertion Force (ZIF) socket which allows the programming of SDIP56 and
SDIP42 packaged MCUs.

A TQFP64 ZIF socket is also provided on the development board, for the
programming of TQFP64 packaged MCUs.

In Situ Programming

In addition to classic MCU programming using ZIF sockets, the ST7MDT2-DVP2
development kit is provided with an In Situ Programming (ISP) functionality. This
allows the user to program a target MCU mounted on an application board.

Only Group 1 target devices (see page 39) support the ISP functionality. In order to take
advantage of the ISP functionality, your application board must be designed to allow for in situ
programming. Only target MCUs provided with a power supply of 5V support the ISP
functionality.

A provided 10-pin flat cable can be connected to the ISP connector (Ref: W2) at
one end, and to an ISP target connector which is contained on the application
board. Refer to the target device's datasheet for details on adding an ISP
connector to your application board. You will find the ISP connector pin number
assignment below, as it is on your development kit board.

{ ISPData
GND <¢ 100 2 ISPaK
3 8 8 4 Reset
5 6
Vob o1 0os ISPSEL
TPaa 90 010 P1—
=N
MB289A

Figure 9: ISP connector

The Windows Epromer fully supports the ISP functionality. For more information
concerning ISP consult the application notes (ref.: AN1179).
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Device installation

Take care when placing the device into a socket so as not to damage the device or the board.
Never insert or remove devices when powered. Devices are powered only during read or write
operations.

Place the SDIP56 device into the zero insertion force (ZIF) socket mounted on the
board (location U6) with the erasure window on top and pin 1 matching the hollow
(unfilled) circle No.1 on the board.

SDIP56 devices should be placed here

ZIF Socket
\ & 0000 R + 80000 +

\

N

r4
z
2 000N /5 800004

SDIP42 devices should be placed here

You